原创

单元测试问题集合:Native library for Attach API not available in this JRE Caused by: java.lang.UnsatisfiedLinkError: no attach in java.library.path

问题描述:
单元测试执行run的时候出现以下报错:

java.lang.IllegalStateException: Native library for Attach API not available in this JRE
Caused by: java.lang.UnsatisfiedLinkError: no attach in java.library.path

解决方案:
ecplise右键单击>Run As > Run Configurations 选择存在的JRE包,点击Run即可;若没有JRE包可选,点击Install JREs添加,点击Ok ,再点击Run即可。

正文到此结束
本文目录